
 

 
Weather Explorer Series
GRIB Explorer

User guide
 

Thank you for choosing GRIB Explorer. You can now display and analyze GRIB
data analyses and forecasts right on your computer screen. GRIB data files can
be viewed as a single weather chart or as an animation sequence of forecasts if
one is available. Whether you are a new or a seasoned GRIB data user, you will
find GRIB Explorer highly flexible and easy system to use that let you focus on
interpreting the data at hand rather than on trying to figure out how to use it.
 
The GRIB Explorer Version 9 supports a large host of weather parameters,
includes valuable tools for thermocline and sub-surface temperature analysis,
incorporates vessel optimum routing routes obtained through OCENS WeatherNet,
and OCENS SnapTrack asset and vessel location plots
 
GRIB Explorer works closely with OCENS WeatherNet which provides an
extensive array of GRIB data files generated by various weather numerical
models. The data is supplied on region by region basis covering almost the entire
world. To access this data, you must have a subscription to the WeatherNet
service.  A per chart fee may apply.  For more information visit www.ocens.com.
 
GRIB Explorer accepts GRIB files that cover moderate geographic extent with
single or multiple weather parameters. Several parameters can be plotted in the
same GRIB chart or GRIB animation sequence.

Getting Started
Take a tour to get familiar
with GRIB Explorer
View Samples
Display sample GRIB
charts covering numerous
regions of the globe.
Updating Weather Explorer
Files
To get the most out of your
Weather Explorer system,
keep your version up-to-
date.
Obtaining Technical
Support

http://www.ocens.com/
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Uninstalling Weather Explorer.

Tutorial.

Tutorial
 

Opening GRIB Files
  To open a GRIB file:

1. On the File menu, click Open OR click on the  icon.
2. In the Open File dialog box, select the GRIB file you want to open and Click on the Open button.

Note:
If the file coverage area coincides with that of any open window, then GRIB Explorer will overlay the file on that
window. Otherwise, the file is displayed in a newly created window. If you want the file displayed in a new window
inspite of an existing window with the same coverage area, then use File | New.

Using the Properties Panel
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The Properties panel contains a wealth of information on the currently displayed chart.
 

  Displayed Time offset that is being used
  Date of the data that is being displayed.
  Which weather files are currently being displayed
  The cursors GPS coordinates and its distance and heading from your home location.

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
By clicking on the 'Plot Options' you will see:
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This window allows you to adjust your Weather Chart Options . You can also make these
adjustments via the Menu and Toolbar by selecting Chart menu, click Options ... OR click

on the  icon OR right click on the chart and click Options ... on the popup menu
then select "Options" :
Be sure to note the Scroll bar on the right of this window as more options may be hidden.
 

 In addition to the basic Chart Options - From this panel you can customize things like
customizing how your contour lines display on the chart.

Click here for an example.
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
When you select the 'Map Options' you will see:
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 From this panel you can customize the background Map. This can also be done via

the Chart menu, click Options ...   OR click on the  icon and select Map.
 

GRIB Explorer Color Key
The color key display the corresponding between the values of the parameters and the colors on the charts. 

  To show or hide the color key:

1. On the View menu, click Color Key, or click on the  icon.
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Menus specific to the color key panel can be activated by right clicking on the panel. The following menu is
displayed:

  To Hide the color key:
1. Right click on the color key and uncheck Color Key.
 

  To change the units of a plotted parameter:
1. Select the parameter from the combo selection at the top of the panel.
2. Right click on the color key and select   Units.
3. Choose the unit you want applied to the selected parameter.
 

  To change the color of a plotted parameter:
1. Select the parameter from the combo selection at the top of the panel.
2. Right click on the color key with and select Color Palette.
3. Choose the color scheme you want applied to the selected parameter.

Adding Date and Time Stamp
The chart's date and time stamp provides quick information on the region, weather parameter name, atmospheric
level and the valid date and time of the chart.  When a GRIB chart is in animation mode, the date and time stamp
panel is constantly updated with the information of the current frame.  The date and time stamp panel can be placed
in the upper-left, upper-right, lower-left or lower-right corner of the chart.



 

8 of 37

 
  To display or Hide the date and time stamp on the all opened charts:
1.  On the View menu, click Date and Time Stamp.
If the Date and Time Stamp menu item is already checked then the date and time stamp will be hidden,
otherwise it will be displayed.  This options will remain in effect in all subsequent charts until changed again.
 

  To add and position the date and time stamp:
1.  On the View menu, click General Options ...
2.  In the "General Options" dialog box, Select Display .
3. Check "Date and time stamp".
4.  Select the position of the image stamp from the combo selection. Possible selections are upper-left, upper-
right, lower-left and lower-right.
5.  Click the OK button OR Click the Apply button if enabled, for instantaneous display of the date and time
stamp on all currently opened charts.

GRIB Explorer Menu and Toolbar
GRIB Explorer toolbar provides shortcuts to some of the most frequently used menu commands. The table below
show the icons, their menu equivalents and the description of the commands. Hovering the mouse over an icon in
the toolbar, Weather Explorer displays a text description of the command.
 

Icon Menu Command Description

File | New Open a New GRIB file

File | Open Open a New GRIB file

View | Refresh Update the drawings of the chart on the screen.

File | Page Setup ... Setup a weather chart for printing.

File | Print Print a weather chart using the current page setup properties.

GRIB | Horizontal Profile Show or hide a horizontal profile of weather data.

GRIB | Time Profile            Show or hide a time profile of weather data.

GRIB | Thermocline Show or hide the Thermocline / FishMap tool

GRIB | 3-D Plot Show or hide 3-D plot of a weather parameter.
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Activate GPS Activate Global Positioning System if available

View | Properties Panel Show or hide Properties Panel. This panel displays home location,
image properties, cursor position and coverage region.

Chart | GRIB Options ... Change current weather chart display options.

View | Color Key Show or hide color palette key.

Zoom | Width Fitting Weather Chart to Window Width Fit current weather chart to
the width of the display window.

Zoom | Height Fitting Weather Chart to Window Height Fit current weather chart to
the height of the display window.

Zoom | Actual Size Fitting Weather Chart to Actual Size Display current weather chart in
its actual dimensions.

Zoom | Region Zoom Zoom on a selected rectangular region of the chart.

Window | Tile Horizontal Tile windows horizontally.

Window | Tile Vertical Tile windows vertically.

Window | Cascade Cascade windows.

Animation | Play Play current animation of weather charts.

Animation | Stop Stop current animation and go to the beginning of the sequence.

Animation | Pause Pause the animation of weather charts at the current frame.

Animation | Previous Move to the next frame in the animation sequence.
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Animation | Next Move to the previous frame in the animation sequence.

Animation | Go To Start Move to the start of the animation sequence.

Animation | Go To End Move to the end of the animation sequence.

File
Using the File menu you can open existing GRIB files, send displayed weather charts to your default printer, and
close Weather Explorer program.

Opening GRIB Files
 To open a GRIB file:

1. On the File menu, click Open OR click on the  icon.
2. In the Open File dialog box, select the GRIB file you want to open and Click on the Open button.
Note:
If the file coverage area coincides with that of any open window, then GRIB Explorer will overlay the file on that
window. Otherwise, the file is displayed in a newly created window. If you want the file displayed in a new window
in spite of an existing window with the same coverage area, then use File | New.

 
Printing GRIB's

  To setup and print a weather chart:

1. On the File menu, click Page Setup ... OR click on the  icon.
2. In the Page Setup dialog box, select the top, bottom, left and right margins, the page orientation and the
position of the color palette key of the chart. The preview window on the right side of the dialog box shows the
results of your selections.
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3. Click on the OK button to save the page setup properties or the Print button to send the chart to the default
printer.
 

  To print a weather chart using existing Page Setup properties:

1. On the File menu, click Print OR click on the  icon.
2. In the Print dialog box, click the Print button to send the chart to the default printer.

Closing GRIB Explorer
  To close Weather Explorer:
1. On the File menu, click Exit.

View
 

Toolbars
  To show or hide Weather Explorer toolbars:
1. On the View menu, click Toolbars and check/uncheck Standard.

Status Bar
  To show or hide Weather Explorer status bar:
1. On the View menu, click Status Bar.

Properties Panel
Properties panel contains a wealth of information on the currently displayed chart. Four sub-panels are common to
all GRIB charts and provide information on:
1. Your home location for distance and bearing computations.
2. General information on the source GRIB file and some of its header information.
3. Cursor position including latitude, longitude, bearing and distance of the mouse position to your home location.
4. Coverage region of the current weather chart.
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All others sub-panels of the properties panel are weather parameter-dependent showing the value of the parameter
at the current mouse position.
 

  To show or hide Weather Explorer properties panel:

1. On the View menu, click Properties Panel, or click on the  icon.
 

For more information, please visit Using Properties Panel.
Color Key

The color key display the correspondence between the colors and the values of the plotted weather parameter.
 

  To show or hide the color key:

1. On the View menu, click Color Key, or click on the  icon.
 

For more details on the color, please visit Weather Explorer Color Keys.
Date and Time Stamp

The chart's date and time stamp provides quick information on the region, weather parameter name, atmospheric
level and the valid date and time of the chart.  When a GRIB chart is in animation mode, the date and time stamp
panel is constantly updated with the information of the current frame.  The date and time stamp panel can be placed
in the upper-left, upper-right, lower-left or lower-right corner of the chart.
 

  To display or Hide the date and time stamp on the all opened charts:
1.  On the View menu, click Date and Time Stamp.
If the Date and Time Stamp menu item is already checked then the date and time stamp will be hidden,
otherwise it will be displayed.  This options will remain in effect in all subsequent charts until changed again.
 

  To add and position the date and time stamp:
1.  On the View menu, click General Options ...
2.  In the "General Options" dialog box, Select Display .
3. Check "Date and time stamp".
4.  Select the position of the image stamp from the combo selection. Possible selections are upper-left, upper-
right, lower-left and lower-right.
5.  Click the OK button OR Click the Apply button if enabled, for instantaneous display of the date and time
stamp on all currently opened charts.
 

For more details on the date and time stamp, please visit Chart Display Options.
Refresh

The refresh command updates the drawing of the chart on the screen.
 

  To refresh a displayed weather chart:

1. On the View menu, click Refresh or click on the  icon.
General Options

General program options allow to set and change:

• your home location
• chart display options
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• measurement units
• your GPS unit

 

  To activate general options:
1. On the View menu, click General Options ...
2. Select the appropriate tab.

Home Location
The Home Location sub-tab allows you to provide information about the geographic location of your 'home', be it
your actual home, a boat or any other location.

Enter your location manually here. If you do not have a GPS attached to your GE, GE will use this manually entered
location as a reference point for all bearing and range measurements. Height is available but seldom considered.
 
By clicking on the icon to the right of the lat/lon table you can assign a color different than the default to this icon.
THe icon represents your Home Location on GRIBs you are processing with GE.
 
The Time Zone section adjusts the time posted on your gribs to local time if you so desire. Select the time zone
offset you prefer. Check the Daylight Saving Time box when this location is under Daylight saving time.
 
If you do not 'Display local date and time on all charts and plots', UTC time and day will be displayed.orget to add
keyword for this topic

Display
Display controls establish how the grib is loaded to your screen and how it displays time and date.
 



 

14 of 37

GRIB files can be loaded in a fashion which fits them to the window, to screen width, screen height, or actual size.
This default can be set by changing the "Open images zoomed to" selection.
 
The Date and Time Stamp option allows you to position the subject stamp at different locations around your screen
while the Calendar color scheme does just that, changes the color scheme to suit your preferences. Just click on the
desktop-style calendar and select the color you like.

Units
This units page allows you to put your preferences in play for a wide variety of measurements, including
 such things as Depth, Speed, Height, Distance, Temeperature, Atmospheric Pressure, and Location.
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Global Positioning System
Before your setup your GPS in GRIB Explorer, please make sure that your GPS is connected to the computer
according to the manufacturer's instructions.
 

  To set your GPS unit in GRIB Explorer:
1. On the View menu, click General Options ...
2. Select GPS.
3. Select the communication port, baud rate, data bits, stop bits and parity.
4. Select NMEA 0183 sentences from which positional information will be extracted.
5. Check "Update home location" if you want to update your home location with GPS information.
6. Check "Plot home location" if you want your position plotted on GRIB charts.
7. Set time out after which GRIB Explorer will stop trying to connect to the GPS unit.
8. If you want to test your GPS unit, click on the "Test GPS ..." button.  If the GPS unit is working properly, you will
see NMEA 0183 sentences displayed in their raw format. Otherwise, GRIB Explorer will display an error message
asking you to check you GPS connection and setup properties.
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Overlay
The Overlay menu provides links to the layering of OCENS SnapTrack and OCENS/FastSeas routing information on
your downloaded GRIB files

Optimal Route
GRIB Explorer includes the ability to overlay WeatherNet / FastSeas routing files onto grib weather and ocean data
you have downloaded, thereby giving you a wholistic context through which to view your routes.

Plot Optimal Route
Routes generated by the OCENS WeatherNet integration of FastSeas optimal routing services can be plotted by
GRIB Explorer as a layer on top of a downloaded GRIB files. This allows you to view your route with the additional
perspective granted by a backdrop of wind, wave, ocean current or any one or more other types of weather and
ocean data of interest to you.
 

 Hover Information
 

Move your cursor into the grib map and over any portion of the optimal route. Rest it over any given spot in
the route for a couple of seconds and you will see a hover pop-up appear.
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This pop-up displays all the information for that specific route node. This information includes for the subject
route waypoint its:

 
Date and local hour
Lat and lon location
Elapsed time since departure
Wind speed in knots
Wind direction (true)
WInd gusting to (knots)
True wind angle
Ocean current speed (knots)
Ocean current direction (true)
Speed over water (knots)
Heading (true)
Course over ground (true)
Speed over ground (knots)
Distance made good since last waypoint.

 
Auto-Plot of Most Recent Route

WeatherNet and GRIB Explorer work together to plot automatically your most recent route in GRIB Explorer. Once
WeatherNet completes a route download and you close the File Transfer screen it creates a copy of your route and
names it route.rte. This file is saved to the Weather Files/Routing folder of your MyDocuments along with the raw
file name. WeatherNet then launches GRIB Explorer to display the GRIB data just downloaded by WeatherNet.
GRIB Explorer looks to the Weather Files/Routing folder for the presence of a route.rte file. If found, it automatically
displays that route and layers it on top of the acquired GRIBs. Since only the most recently received route is
renamed to route.rte by WeatherNet, you are always looking at your most up-to-date route calculation via the GRIB
Explorer auto-load.
 
Note that GRIB Explorer will always complete its launching of GRIB files handed to it by WeatherNet by looking for
the route.rte file for layering.If it has been some time since you last requested a route, you will then be looking at
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a route which may be older than the weather or ocean data your viewing. Once you are finished with the voyage
associated with a given route consider deleting route.rte from the WeatherFiles/Routing folder.

Manual Plot of Any Route
You can manually plot in GRIB Explorer any route you have ever downloaded and archived. For GRIB Explorer to
display this, the geographic coverage of your GRIB background must overlap with the region covered by your route.
 
Once a GRIB including the region covered by your route is open in GRIB Explorer, go to the GRIB Explorer Overlay
menu and select Plot Optimal Route. GRIB Explorer will automatically move to the Weather Files/Routing folder
and show you the routes available there.
 

WeatherNet saves routing files according to the following naming convention:
 

route_2017-03-09-8-0_35N_70W_40.78N_70.84W.rte
 
It defines the start date and local hour of the route: 2017-03-09-8-0, then
the starting location: 35N_70W and
the ending location: 40.78N_70.84W
 

Click on the file to highlight the route of interest to you and then click Open. The route will be opened and layered
onto your grib display.

Rhumb Line Plot
In addition to the Optimal Route, GRIB Explorer also plots the Rhumb Line route between your starting and finishing
locations.

Route Reference Circle
As you advance from frame to frame of weather or ocean information in GRIB Explorer you should notice a circle
moving along the path of your route. This circle provides a reference between the current date and time of the
grib weather info in the background and where you are along your optimal route at that same date and time. You
might notice that the Reference Circle doesn't appear when you first start or get near the end of your route. This is
because in the grib file you selected to download along with your route, there is no weather data for these earlier or
later dates. Bear this in mind when you request in WeatherNet the multi-day grib to associate with your route.

View Optimal Route
Once you have plotted your Optimal Route on a GRIB Explorer grib background you can use the View Optimal
Route menu to view a table of statistics covering each of the waypoints in your route.
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The report provides in one location for all waypoints the same information that you can view on a waypoint by
waypoint basis when you hover your cursor over a single waypoint along the actual route itself:
 

Elapsed Time (since departure)
Date and local hour
Lat and lon location
Elapsed time since departure
Wind speed in knots
Wind direction (true)
WInd gusting to (knots)
True wind angle
Ocean current speed (knots)
Ocean current direction (true)
Speed over water (knots)
Heading (true)
Course over ground (true)
Speed over ground (knots)
Distance made good since last waypoint.
 

Overlay Options
Overlay Options affect how Bathymetry data and your SnapTrack or Optimal Route overlays appear.

SnapTrack / Optimal Route
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Vessel ID, Display Date and Time, Display Position Number and Connect Position parameters pertain only to
SnapTrack plotting.
 
Color: Click on the Color box to assign a color to your Optimal Route path or SnapTrack positions.

Bathymetry
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Zoom
Zooming is the process by which an image is enlarged for a detailed view or reduced for a global view.  Zooming
operations in Weather Explorer consist of either setting the zoom level or using one of the fitting method described
below.

Setting Chart's Zoom Level
  To set the zoom level of current chart:

1.  On the Zoom menu, click Zoom To, then select the percent zoom you want, OR click the  icon.
 
Note: In the zoom level list, the first disabled zoom refers to the current zoom level of the chart.  This item is not
selectable but is displayed for information purposes only.

Fitting Weather Chart to Window Width
  To fit the current chart to window width:

1.  On the Zoom menu, click Width OR click on the  icon.
 
Regardless of the actual dimensions of the loaded image, GRIB Explorer will fit in this case, the chart width to the
display window so that the entire horizontal extent of the image is visible.  In doing so, Weather Explorer keeps the
aspect ratio of image width to height constant.  Consequently, the height of the image can either extend beyond or
be contained within the height of the display window. 

Fitting Weather Chart to Window Height
  To fit the current chart to window height:

1. On the Zoom menu, click Height OR click on the  icon.
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This method consists of fitting the chart to the height of the display window so that the entire vertical extent of the
image is visible. By keeping the aspect ratio constant, the image width may either extend beyond or be completely
contained within the width of the display window.  

Fitting Weather Chart to Actual Size
  To display the current chart in its actual size:

1.  On the Zoom menu, click Actual Size OR click the  icon.
 
When an image is displayed in its actual size, there is a one-to-one correspondence between the pixels on the
display screen and those of the image.  An image displayed using this method keeps its realistic appearance and
no pixels need to be thrown away or added to the display screen.  If the loaded image is much larger that the main
display window, only a portion of the image is visible but can be scrolled up and down or left and right to expose
other regions of the image.  If on the other hand, the image is smaller than the display window then some portions of
the display window will be blank filled with the window’s background theme.  In trying to display an image in its actual
size, GRIB Explorer always keeps the aspect ratio of width to height constant so as to minimize any distortions in the
display of weather charts.

Fitting Weather Chart to Window
  To display the entire current chart fitted to the size of the window:
1. On the Zoom menu, click Window.

 
Depending on the relationships between the image and the display window width and height, GRIB Explorer either
fits the image to the width or to the height of the display window so that the entire image is visible to the user.  If fact,
this fitting method is just an automatic version of Fitting Weather Chart to Width and Fitting Weather Chart to Height. 
This method provide a global view of the loaded weather chart.

Region Zoom
 To zoom in on a particular region

1. On the Zoom menu, click Region Zoom OR click the  icon.
 
Region Zoom lets you box a sub-set of the GRIB open in front of you and then zoom that sub-section to fill the
window.
 

Click Region Zoom and then move your mouse cursor into the GRIB.
Move the cursor to what you want to be the upper left corner of your subsection.
Click-Hold-and Drag down and to the right to create a box. When that box reaches your desired size, release
the cursor. The box subsequently expands to fit the page.

 
Window Pan

The Pan sub-menu is useful if you are already zoomed into a sub-section of your open GRIB and then want to
quickly move your zoomed block level to another area on the GRIB.
 
If so, open the Window Pan tool, grab the outline box in the Pan tool with your left cursor and move it to another area
of the map. You will see an echo of this movement in the main screen grib a few moments later.
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GRIB
 

GRIB Options
  To change the plot options of a weather parameter:

1. On the GRIB menu, click GRIB Options ... OR click on the  icon OR click on the GRIB with the right
mouse button and click GRIB Options ... on the popup menu:
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• To turn on/off a particular weather parameter, select 'Data' and then click on the item you want to turn on /off.
• To change the map options, select 'Map'.
• To change how you view the various is weather parameters, select 'Options'.
• To view the overall coverage of the data select 'Coverage'.

 
Data

Provides a brief summary of the data file or files you have presently loaded into GRIB Explorer along with their Valid
Times.

Map
This controls the look and feel of the background map on which your GRIBs are plotted.
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Map Type: You have the option of projecting your GRIBs on to either a Mercator or a Rectangular projection.
 

Quick Tip: This selection cannot be made while a GRIB is open in GE. The GE screen must be blank to
select between Rectangular or Mercator. Once you do so click the Apply and OK button and then open a
GRIB.
 

The Map itself: Click on the thumbnail map here to see a range of different colors and background options. Then just
tap on the map background you think you like the most. Click OK to apply the sets to the GRIB you are reviewing.
 
Resolution: Some map backgrounds come in different low, medium or high resolutions. Those can be selected
here.
 
Map Background, Land Areas, Ocean Areas: If none of the canned backgrounds are to your liking, customize your
look by assigning specific colors to these map sections.
 
Coastlines, Political Boundaries, States and Provinces, Rivers, Geographic Grid and Cities: Choose what features
you want drawn on your GRIBs, the density and texture of the line used to draw them and its color.
 
Latitude and Longitude Interval:  A lat/lon grid is plotted over the top of each GRIB you download. These settings
control how close or far apart you want each line of that grid to be spaced.

Options
This is a powerful section that allows you to finesse how you want to display each of the different data types you are
analyzing. Play around with this page. Really that's the best way to find out what works best for you. Or attend one
of Chris Parker's weather seminars ( http://www.mwxc.com ) or purchase his GRIB Analysis book. There is likely no
one we know who can better manipulate these settings to identify important weather features.
 

http://www.mwxc.com
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Selected Products:
 
If you have more than one GRIB product
open in GRIB Explorer, be sure to bring into
'focus' the one you want to manipulate by
having it front and center here. Click on the
drop down arrow to select other GRIBs and
bring them into focus.
 
The More button provides summary
information about your GRIB in its Product
Details section and a map which places the
segment of the earth at which this group is
looking in the context of the whole earth in
its Coverage Area sub-tab.
 

 
 
Options:
 
Choose whether you want the parameter displayed as a contour line, a color-filled contour, a graphical symbol, eg a
wind barb, a color-fille contour or a gradient fill. Try them all and see which suits this parameter and your preferences
best.
 

Display values: For some gribs, eg wind or wave, that are clearly point-based you can tell GRIB Explorer to
display the actual value of that parameter at that location right on the grib in front of you. Check this box if
that appeals to you.

 
Slow to Fast: This controls the speed of the animation of one frame to the next in multi-frame, multi-day
GRIBs.

 
Advanced Settings:
 
Adjust the font, color, and other characteristics of contour and data labels you may add to your GRIB analysis.
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Coverage
This shows you the location and size of the specific grib you are viewing in the context of the whole earth map.
 

Horizontal Data Profile
The horizontal data profile is a plot of the values of the main weather parameter located on a great circle line
between two arbitrary points on the chart. You can move either points in any direction by holding the left mouse
button and dragging to the desired new point. The horizontal data profile works for both single frame and animated
charts.
 

  To draw the horizontal profile on a chart:
1. On the Chart menu, click Horizontal Profile.
A great circle line will be draw across the main display window. You can move the extreme points of the line in
any direction to get a new line. Below is an example of a horizontal data profile of waves significant height and
mean period for the Atlantic ocean:
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Moving the mouse cursor over the plot provides information such as latitude, longitude, bearing, distance from your
home location, and values of the parameters at the corresponding point on the chart. This option is not available
when a chart is in animation mode.

Time Profile
The time data profile is a plot of the values of the main weather parameter located at the mouse position through
time. As you move your mouse position, a new time plot is displayed. The time data profile works for multiple time
frame GRIB charts.
 

  To draw the time profile of a GRIB chart:
1. On the Chart menu, click Time Profile.
In the example below, the time profile plot displays waves mean period, waves significant height and wave
direction for the cursor location 31° 51.665' N  76° 37.930' W for all time frames in the sequence of forecasts. The
time label in cyan corresponds to the current frame of the forecast sequence.  Direction information is show on he
right side of the plot in green arrows.
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3-D Plot
The 3-Dimensional plot in GRIB Explorer displays the selected weather parameter in 3-D space of latitude, longitude
and height corresponding to the value of the parameter.  The 3-D plot gives a more global view of the parameter and
helps identify developing weather phenomena that may otherwise be missed.
 

  To draw the 3-Dplot of a weather parameter:
1. On the Chart menu, click 3-D Plot.
The following example shows air temperature of the the Atlantic ocean in a 3-D plot. You can rotate the plot by
pressing the arrow keys. You can zoom in and out by pressing the I and O keys, respectively.
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Moving the mouse cursor over the plot provides information such as latitude, longitude, bearing, distance from
your home location, and value of the parameter at the corresponding point on the plot. This option is not available
when a chart is in animation mode.

 
Thermocline and Fish Map

The GRIB Explorer (GE) Thermocline tool is built exclusively for the Thermocline product available in OCENS
WeatherNet.  A YouTube video discussing the Thermocline and FishMap tools as well as sub-surface temperature
and mixed layer depth can be found
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The Thermocline product is available in WeatherNet at these locations:
 

In Portal mode: Go to the GRIB Fishing wizard page by clicking on 
In Basic mode: In the Tuna Pacific, Tuna Atlantic and Europe Fishing personalities
In Library mode: Go to GRIB FishingSea TemperatureSubSurface Sea Temperatureand drag the ‘Sub-surface
thermocline, 0 to 1000 meters’ file to your download folder. Note there are a number of sub-surface temperature
layers available there as well.
 
Download the Thermocline product for the ocean region of interest to you. We recommend a 5x 5 grid for downloads
done offshore with a low bandwidth Iridium satellite phone. Higher bandwidth services or onshore downloads can, of
course, support larger download grids.
 
Once the download completes, WeatherNet will launch GRIB Explorer automatically to view and analyse the data.
 

Launch the Thermocline tool from its GRIB Explorer icon or from the GRIB menu in GRIB Explorer.
 
Fish Species
A total of 40 fish species are presented on the list. Select the Fish Species you are targeting. Once you do so, a
shaded column appears on the graph ‘paper’ to the right of the fish species list. Let’s call this vertical column the
Optimum Temperature (FishOT). Running across the top of the graph are the color-coded temperatures present in
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one or more layers of the sub-surface temperatures downloaded in your Thermocline file.  Running along each side
are depths. To the left side, depths are presented in meters. To the right side, depths are presented in feet.
 
NOTE: Temperature ranges commonly associated with each target species appear as a default for each species.
Disagree with those ranges? No problem. Simply edit the upper and lower temperatures to values you prefer and
click Save. New temperatures are saved on a species-by-species basis. Should you want to switch back to the
original values, click on Default and the original temperatures for that species will be reloaded.
 
NOTE: Are you targeting a species not listed on the pull-down? Scroll to the bottom of the list to find Other Species
1, 2 or 3. Select one of these and customize the temperature ranges to your liking for that species.
 
Now move your cursor into the temperature field of the GRIB file in the background. Five elements immediately
appear:
 
1)     A red line trending from the upper right area of the graph down and to the left. This is the Thermocline lying
under the point in the ocean at which your cursor is located in the background map. Temperatures as a function
of depth are presented from the surface to a depth of 1000 meters. Look at the thermocline carefully. The curve
generally drops straight down for tens if not hundreds of meters before breaking sharply to the left indicating a rapid
drop in temperature at that depth. The depths above or prior to this sharp drop represent the Mixed Layer in the
ocean at this location. The sharper the break the more pronounced the shift between underlying colder water and
warmer upper layers.
2)     A second element of the graph is a green, horizontal bar extending from the Thermocline curve across and to
the left until it encounters the depth axis. We’ll call this bar the Optimum Temperature at Depth or OT@D bar. The
upper edge of the OT@D bar is equal to the maximum temperature for your target species and it is positioned to
show you the depth at which this temperature occurs in the ocean underneath your cursor. Similarly, the lower edge
of the OT@D bar represents the minimum temperature for your target species and the depth at which that minimum
temperature is located. It too is annotated with that depth in m and ft. In short, this horizontal bar shows you the
depths at which the optimum temperatures for your target species exist in the ocean at the position of your cursor.
3)     Third, look for a green more-or-less triangle-shaped segment where the vertical column of your FishOT (the
vertical column) intersects with the horizontal bar of the depths at which these temperatures occur, the OT@D. This
triangle represents the Fishing Volume (temperature x depth) for your target species at this location. In general, the
bigger this ‘triangle’ the more opportunity to find your target at this location.
4)     Fourth, we also allow you to adjust the Fishing Volume for your vessel or gear. Even though the thermocline
graph may show a lot of water at the preferred temperatures for your target at this location, what if the temperatures
are too deep for you to use? The white line you see cutting across the graph is the means you can use to adjust the
Fishing Volume to your boat or gear. We’ll call this the Maximum Fishing Depth (you can adjust its depth by clicking
the Edit button). Consequently, its important to pay attention to only that portion of the Fishing Volume triangle which
is above the Max Fishing Depth line. For example, if all the preferred temperatures (and thus the Fishing Volume
triangle) for the species you are targeting are deeper than you can fish, then your fishing volume is zero.
5)     Last, below the graph is presented the latitude and longitude of your cursor position as well as the bearing and
range from your vessel’s location to the cursor position. Bearing and range either references your GPS position if
linked to GE or positions manually entered within the View—General Options—Home tab of GRIB Explorer.
 
Move your cursor around the downloaded Thermocline file and observe how the Thermocline, the OT@D bar and
the Fishable Volume triangle change with location. Again, bigger triangles mean there is more water at this location
which is at temperatures that match your target species Optimum Temperature. Smaller triangles mean there is less
such water. Other factors being equal, opportunities for successful fishing outcomes should increase as the size of
the Fishable Volume triangle increases.
 
FishMap™
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We’ve talked about how important is the Fishing Volume triangle. We’ve suggested you move your cursor around
the background GRIB to observe how this triangle changes with location. And we’ve reminded you that its only that
portion of the Fishing Triangle which is above the Maximum Fishing Depth for your vessel or gear that really should
matter to you.
 
What if you then had a means of assessing how Fishing Volume and thus fishing opportunity changes across the
whole field of temperatures around you? A means of integrating not only across the ocean but also looked vertically
‘into’ the ocean? That summarized this in one color-coded picture highlighting how the fishing volume for your target
and your boat/gear changes in the ocean around you?
 
We’ve done that…This is FishMap
 
 
Click on the FishMap button. A second graph now appears depicting the same area of the ocean that you have been
looking at with your background GRIB and the Thermocline chart. Except that now we are no longer looking at the
temperatures themselves but instead the amount of water containing target temperatures positioned above your
maximum fishing depth.
 
What’s going on here? In one step, GRIB Explorer has swept through your background GRIB at ALL depth levels,
calculated the Fishing Volume triangle and adjusted it for your Maximum Fishing Depth, at each of those points. It
then color coded the volumes it came up with and plotted them as the Fishing Map, shading them from cold blue
to hot red (see the palette to the left of the map). As the colors move towards red, the Fishing Volumes increase. In
short, your eye is quickly drawn to the bright yellows and reds in the Fishing Map because those areas of the ocean
contain more water at your target temps and depths than do the areas shaded green and blue. 
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You can see this in another way by moving your cursor into the FishMap. Observe the scale above the Map. This
scale is a direct readout of the Fishing Volume at the point of your cursor. It extends from 0 on the left to your
Maximum Fishing Depth on the right. The size of the green ‘fill’ increases as you move your cursor into the yellow
and red areas of the Fishing Map. We abbreviate the actual volume at each point inside of the green fill with ‘xx fv’.
But the absolute value of FV is quite unimportant. Instead, it is really the relative size of the FV at this point of the
ocean to the other areas of the ocean around it that matters to you as you route to fishing opportunities.
 
Integration
 
Some feature nuances you should find useful.
 
1)     As you move your cursor around the background Thermocline GRIB note how a position mimic appears at the
corresponding location of your Fishing Map and vica versa;
2)     The background GRIB defaults to show you the surface layer as your first view. You can view any other layer

by finding the Depth icon  in the GE tool bar and selecting the depth to serve as your
background. Remember, however, regardless of the depth which appears as your background, the GRIB Explorer
Thermocline tool and Fishing Map integrate across all depths.
 
3)     The units (F or C) that are presented on your Thermocline chart and/or for FishOT are controlled by the Plot
Options sidebar available on the right or left side of your main screen.
 
EDIT:
 
Associated with each fish species is that species Optimum Temperature range. If you disagree with the default
Optimum Temperature range for that species, click the Edit button and enter your own maximum and minimum
temperatures. Be sure to click Save to record your changes.
 
You can also set the Maximum Fishing Depth for your vessel from the Edit button. Likewise, be sure to click save to
record your changes to the maximum fishing depth.
 
Edits to Optimum Temperature range and Maximum Fishing Depth are saved on a species by species basis.
Likewise, if you click on the default button, values for this species and this species alone are returned to their default.

WeatherNet
GRIB Explorer works closely with OCENS WeatherNet which provides an extensive array of GRIB data files
generated by various weather numerical models.  The data is supplied on region by region basis covering almost
the entire world.  To access this data, you must have a subscription to the WeatherNet service.  A per chart fee may
apply.  For more information visit www.ocens.com.
 

  To launch OCENS WeatherNet from your GRIB Explorer program:
1. On the main menu, click WeatherNet and then Launch WeatherNet.
 
Note:
If the WeatherNet program is not installed on your machine, an error message is displayed asking you to install
the program and try again.
 

GRIB Explorer is joined by its sibling, MetMapper. But whereas GE focuses on GRIB data analysis OCENS
MetMapper provides unique tools with which to process weather charts, ocean charts and text information. For more
information visit www.ocens.com.
 

http://www.ocens.com/
http://www.ocens.com/


 

35 of 37

  To launch OCENS MetMapper from your GRIB Explorer program:
1. On the main menu, click WeatherNet and then Launch MetMapper.

Window
  To tile windows horizontally:

1. On the Window menu, click Tile Horizontal OR click on the  icon.
 

  To tile windows vertically:

1. On the Window menu, click Tile Vertical OR click on the  icon.
 

  To cascade windows:

1. On the Window menu, click Cascade OR click on the  icon.
 

  To close the current weather chart, i.e., the chart that has the focus:
1. On the Window menu, click Close.

 
  To close all opened windows:
1. On the Window menu, click Close All.
 
At the base of the Window menu you will also find a list of all the GRIBs now open in GRIB Explorer. Its a quick
way to switch between one grib or another and view them in full screen mode.

 
Help

This Help file is accessed from the Help menu.
 
Your GRIB Explorer version number is displayed under the About sub-tab.
 
A handy set of GRIB samples can also be accessed from the Help menu. These samples are described under their
own heading, GRIB Samples in this Help file.

GRIB Samples
GRIB Explorer samples are located in "\SAMPLES" sub-folder in your installation directory.  There are both single-
time frame weather charts and animation forecasts by selected geographic region. To activate these samples, you
can either use the File menu system to open the desired GRIB file or follow the steps below.
 

  To view GRIB Explorer samples:
1.  On the Help menu, click Explore Samples .
2.  In the "GRIB Samples" dialog box, choose your region of interest from the combo selection.
3.  Double-click on the GRIB data type thumbnail you want. 
 

 The following geographic regions are included in the samples: 
Atlantic Ocean

This sample includes the following GRIB charts:   
    1. Total precipitation using contour lines.
    2. Air temperature 2 m above ground in color-filled contours.
    3. Wind speed and direction at 500 mb using wind barbs.
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    4. Surface wind speed and direction using wind barbs.
Mediterranean Sea

This sample includes the following GRIB charts:   
    1. Air temperature 2 m above ground in color-filled contours.
    2. Total precipitation using contour lines.
    3. Mean sea level pressure using contour lines.
    4. Wind speed and direction at 500 mb using wind barbs.

North Europe
This sample includes the following GRIB charts:   
    1. Air temperature 2 m above ground in color-filled contours.
    2. Total precipitation using contour lines.
    3. 500 mb geopotential height in color-filled contours.

North Pacific Ocean
This sample includes the following GRIB charts:
     1. Total precipitation using contour lines.
    2. Air temperature 2 m above ground in color-filled contours.
    3. Total cloud cover.

Atlantic Ocean
This sample includes the following GRIB charts:   
    1. Total precipitation using contour lines.
    2. Air temperature 2 m above ground in color-filled contours.
    3. Wind speed and direction at 500 mb using wind barbs.
    4. Surface wind speed and direction using wind barbs.

Argentina
This sample includes the following GRIB charts:
    1. Air temperature 2 m above ground in color-filled contours.
    2. Total precipitation using contour lines.
    3. 500 mb geopotential height in color-filled contours.
    4. Wind speed and direction at 500 mb using wind barbs.
    5. Mean sea level pressure using contour lines.

Australia
This sample includes the following GRIB charts:   
    1. 500 mb geopotential height in color-filled contours.
    2. Air temperature 2 m above ground in color-filled contours.
    3. Total precipitation using contour lines.

Updating GRIB Explorer
To keep your GRIB Explorer software up to date, please check periodically www.ocens.com for new revisions,
service packs, bug resolutions and other important information about Weather Explorer.
 

  To check your current version of Weather Explorer:
1. On the Help menu, click on About. Both the version and the build number of Weather Explorer currently
installed on your machine, will be displayed in this dialog box.

Uninstalling GRIB Explorer
  To uninstall GRIB Explorer:

1. Close GRIB Explorer.
2. On the taskbar, click the Start menu button to open the Start menu.
3. Choose Settings | Control Panel. The Control Panel opens.
 

http://www.ocens.com/grib_explorer
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4. Double-click the Add/Remove Programs button. The Add/Remove Programs Properties dialog box
opens.
 
5. If necessary, click the Install/Uninstall tab to bring it to the front.
 
6. Scroll through the list box to find GRIB Explorer.
 
7. Highlight GRIB Explorer.
 
8. Click the Add/Remove button. The Uninstall setup program starts.
 
9.  Follow the on-screen instructions.

Contact Information
You are our most valuable asset. If you have any questions, comments, suggestions, or complaints, we want to hear
from you. Please contact us via: 
 
Phone: 00 1.206.878.8270
 
Email: support@ocens.com

mailto:support@ocens.com?GRIB Explorer
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